Location:Home > HTML5 声明兼容IE的写法

HTML5 声明兼容IE的写法

<!DOCTYPE html> <!--[if IE]> <meta http-equiv="X-UA-Compatible" content="IE=8" /> <![endif]--> <!--[if IE 7]> <meta http-equiv="X-UA-Compatible" content="IE=7" /> <![endif]--> <!--[if IE 6]> <meta http-equiv="X-UA-Compatible" content="IE=6" /> <![endif]-->

<!DOCTYPE html>是HTML5的声明,主流的游览器中只有IE8及以下版本不支持,这样IE会进入Quirks模式。但之后的声明可以强制指定IE的呈现模式,所以<!DOCTYPE html>声明对IE就无影响。

HTML5并没有XHTML那么严格,对于一般的xhtml页面,基本都不通完全通过W3C验证标准,而改为HTML5声明后基本都能过。

Recommend:HTML5在IE下兼容placeholder属性的jquery插件

折腾一下午,总算解决了这个比较蛋疼的问题。 前端用的bootstrap做的,所以很多html5 结果到ie下面一测,乖乖。不得了,所有的input里面的placeholder等都出不来了。 哭吧。   百度关键词 jquery html5 placeholder 查找   果然都是高手

Recommend:jquery html5 实现placeholder 兼容password ie6

//判断浏览器是否支持 placeholder属性 function isPlaceholder(){ var input = document.createElement('input'); return 'placeholder' in input; } //对不支持placeholder的浏览器处理 if(!isPlaceh

Your Answer
(Ctrl+Enter To Post)   
    Copyright © 2015-2017 163JAVA.COM All Rights Reserved.